Table of contents
Atlantis Word Processor logo
Atlantis Word Processor
Search
Creating tables

The "Insert Table" dialog

To create a new table, click where you want to insert the table, and choose the "Table | Insert | Table..." menu command or click the corresponding "Insert table" Button image toolbar button. In the "Insert Table" dialog, enter the desired number of columns and rows, then click the "OK" button:

The 'Insert table' dialog

Note that you can always change the number of rows or columns of a table at a later time.

Quick Tables

Clicking the down arrow attached to the "Insert table" toolbar button:

The 'Insert table' button

displays the Atlantis table gallery (or Quick Tables panel):

Quick Tables

A single click on any of these Quick Tables thumbnails inserts the corresponding table into the active document.

The menu attached to the "Insert table" button includes an "Edit Quick Tables" command:

Edit Quick Tables

It opens the dedicated folder of the Atlantis Clip Library where the Quick Tables are stored as individual clips:

Quick Tables

Table clips from this dedicated folder can be added/removed/edited in the same way as any other clip in your other Clip Library folders.

Any table included in a document can be added to your Atlantis Quick Tables. Simply select the table in the document, right-click the selection, then choose "Add to Clip Library..." in the menu:

Add to Quick Tables

Atlantis will automatically suggest the "Tables" folder of the Clip Library as the host folder for the new table clip. All you need to do is specify a descriptive name for the clip.

Note that you could place table templates as Clip Library items in any folder or sub-folder of your Atlantis Clip Library. And use them as any other clip item. But the Quick Tables panel attached to the Insert Table toolbar button will only offer immediate access to the tables located under the folder dedicated to tables, i.e. the Clip Library Tables folder.

Creating tables through keyboard

New tables can be created directly through the keyboard. To do so, in a new blank paragraph, type tab characters separated with the "+" sign:

Tab characters

Each "+" sign corresponds to a vertical table border. Each tab character (or a continuous sequence of tab characters) represents one table cell. So in the example above, 5 tab characters and 6 "+" signs indicate a table row with 5 cells.

Pressing Enter after the last "+" sign, automatically converts the typed sequence to a table row with the corresponding number of cells and cell widths, ready for text input:

Convert tab character to a table

A sequence of multiple tab characters leads to a wider cell. For example, typing the following sequence of "+" signs and tab characters:

Tab characters

and pressing the Enter key, creates the following table row with wider cells:

Convert tab character to a table

Converting text to table

In most cases, structured data are represented in documents within cell tables. But sometimes such data are stored as ordinary text where the separation between structural items is realized through some character. In the example below, items of the list with persons' name, age, and location are separated through tab characters:

Tab-separated list

Each "row" of data is terminated with a paragraph end mark:

Tab-separated list

Quite often such lists of tabular data can be found in plain text documents that cannot contain proper tables. But they are also quite often used in formatted documents.

Such a tabular list can easily be converted to a table in Atlantis. To do so, select the list with the keyboard or mouse:

Selecting table

then choose the "Table | Insert | Table..." menu command or click the corresponding toolbar button Button image. This will display the "Convert Text to Table" dialog:

The 'Convert Text to Table' dialog

where you need to specify which character Atlantis should consider a column separator (in our example, the tab character), and how many columns of items are actually present in your list (3 columns in this case, for name, age, and location). However, note that in most cases Atlantis will identify the separator character and the column count automatically. In such cases, you'll only need to click the OK button to convert the selected text to a table:

Cell separator

A tab character is the most common separator for structural lists of data. But you can also convert lists using any other character as a separator, like, for example:

Cell separator

or:

Cell separator

You could even find each list item in a separate paragraph:

Cell separator

To convert such a list to a table, you will often need to manually specify the desired number of columns in the "Convert Text to Table" dialog:

The 'Convert text to table' dialog


Now let's suppose that the text to be converted to table is immediately preceded or followed by a proper table, like this:

Followed by a table

If you select that text:

Select text

and convert it to a table through the "Table | Insert | Table..." menu command or the corresponding toolbar button Button image, the selected text will automatically be incorporated into the neighboring table:

Incorporated into the neighboring table

Default table properties

You can specify how newly created tables should be formatted by default:

  1. Click the "Insert table" Button image toolbar button, or choose the "Table | Insert | Table..." menu command.
  2. Click the "Default Properties" button:
    The 'Default properties' button
  3. Click the "Edit" menu item:
    The 'Edit' menu command
  4. The Atlantis "Default Table" document will open. It contains a table with the current default properties:

    The default table
  5. Click "Table | Table Properties..." on the Atlantis main menu, and use the "Table Properties" dialog to adjust the properties of this default table (you can apply different margins, border widths, border colors, cell shading, cell spacing, etc).
  6. Click the "File | Save" command or press Ctrl+S to save changes.
  7. Press Ctrl+W to close the "Default Table" document.

From then on, any new default table that you create in Atlantis will automatically bear the newly-defined default table properties. For example, you could instruct Atlantis to create borderless tables, or tables with thick outside border, or tables with cell shading applied to the header row, etc.

Here is another way to change the default table properties.

If your document contains a table whose properties you'd like Atlantis to apply automatically to new default tables, you can right-click the table in the document window, choose "Table Properties..." from the context menu, then press the "Default..." button in the Table Properties dialog:

The 'Default' button

Now at times you might want to revert to the original ("factory") default table properties.

Simply click the "Insert table" Button image toolbar button, or choose the "Table | Insert | Table..." main menu command, and press the "Default Properties" button in the "Insert Table" dialog:

The 'Default properties' button

Then choose the "Restore" menu item:

The 'Restore' menu item

See also...