v4.3.3.0 "don't" and "doesn't" are being autocorrected to "don'it" and "doesn'it"

General comments and questions. Technical support.
Post Reply
MaximilianKohler
Posts: 18
Joined: Wed Jun 15, 2016 6:42 am

v4.3.3.0 "don't" and "doesn't" are being autocorrected to "don'it" and "doesn'it"

Post by MaximilianKohler »

Searching this forum doesn't work because:
Search found 471 matches: "doesn'it"

Searched query: doesn it

ignored: it
It happens even after I imported an older (working) AutoCorrect Options English (United States).txt. And 'it doesn't even exist in any of the autocorrect files. Nor in the new Atlantis.ini.

Also, the "change case" buttons in the toolbar are blinking. I don't think 3.x did that, and it's kind of annoying.
User avatar
admin
Site Admin
Posts: 2730
Joined: Wed Jun 05, 2002 10:48 pm
Contact:

Re: v4.3.3.0 "don't" and "doesn't" are being autocorrected to "don'it" and "doesn'it"

Post by admin »

It happens even after I imported an older (working) AutoCorrect Options English (United States).txt. And 'it doesn't even exist in any of the autocorrect files. Nor in the new Atlantis.ini.
You can launch a test copy of Atlantis with factory settings to make sure the issue is not caused by your current Atlantis settings.
Also, the "change case" buttons in the toolbar are blinking. I don't think 3.x did that, and it's kind of annoying.
These buttons become unavailable (grayed-out) when they are not applicable to the current document selection.
MaximilianKohler
Posts: 18
Joined: Wed Jun 15, 2016 6:42 am

Re: v4.3.3.0 "don't" and "doesn't" are being autocorrected to "don'it" and "doesn'it"

Post by MaximilianKohler »

I used the test copy of Atlantis with factory settings and the autocorrect bug doesn't occur there. What would be the next steps?
User avatar
admin
Site Admin
Posts: 2730
Joined: Wed Jun 05, 2002 10:48 pm
Contact:

Re: v4.3.3.0 "don't" and "doesn't" are being autocorrected to "don'it" and "doesn'it"

Post by admin »

You can email your Atlantis.ini from the Atlantis user files folder (by default "My documents\Atlantis") to support@atlantiswordprocessor.com.
User avatar
admin
Site Admin
Posts: 2730
Joined: Wed Jun 05, 2002 10:48 pm
Contact:

Re: v4.3.3.0 "don't" and "doesn't" are being autocorrected to "don'it" and "doesn'it"

Post by admin »

Thanks for the INi file. There is a "t - > it" "replace with" item in your AutoCorrect settings. There is also a number of invalid "replace with" items (probably encoding problem).
Attachments
t_it.png
t_it.png (22.6 KiB) Viewed 3100 times
invalid_encoding.png
invalid_encoding.png (22.34 KiB) Viewed 3100 times
MaximilianKohler
Posts: 18
Joined: Wed Jun 15, 2016 6:42 am

Re: v4.3.3.0 "don't" and "doesn't" are being autocorrected to "don'it" and "doesn'it"

Post by MaximilianKohler »

Wow, that is super strange. I didn't make any changes to it, so I was going to say that it had to have been corrupted simply by installing v4.3 over v3.3. But then I looked at backups and they all have that "t to it" as well. Yet it never manifested in v3.3.

I also saved a copy of the v3.3 AutoCorrect Options English (United States).txt before upgrading, and then I exported the v4.3 one and they had many differences even though they should have been the same. The v4.3 one had new stuff, and also many missing entries.

Regarding the encoding issue, I guess it would have to be from opening the .ini with notepad++?

I saved the current AutoCorrect Options English (United States).txt and opened it with notepad.exe and it shows the bad characters and says "UTF-8 with BOM" at the bottom right. I opened an older version from v3.3 with notepad.exe and the characters are normal, and it's "UTF-8", but when I imported it into Atlantis nothing changed.

I successfully imported a v4.3 txt file that is "UTF-8 with BOM". So it seems that Atlantis changed the format it exports in, and old versions aren't compatible with newer versions of atlantis?
User avatar
admin
Site Admin
Posts: 2730
Joined: Wed Jun 05, 2002 10:48 pm
Contact:

Re: v4.3.3.0 "don't" and "doesn't" are being autocorrected to "don'it" and "doesn'it"

Post by admin »

You should avoid making changes to the Atlantis.ini file using third-party applications. At least always make a backup copy.

There have been many changes in Atlantis since version 3.3. Importing too old settings would not always work flawlessly.
MaximilianKohler
Posts: 18
Joined: Wed Jun 15, 2016 6:42 am

Re: v4.3.3.0 "don't" and "doesn't" are being autocorrected to "don'it" and "doesn'it"

Post by MaximilianKohler »

admin wrote: Sun Aug 27, 2023 8:09 pm There have been many changes in Atlantis since version 3.3. Importing too old settings would not always work flawlessly.
Hmm, I can understand that notion, and other software works that way too, but autocorrect settings (a .txt file) seem basic enough that they should be able to be kept intact (and compatible) when upgrading Atlantis.

EDIT:
Also, the "change case" buttons in the toolbar are blinking. I don't think 3.x did that, and it's kind of annoying.
These buttons become unavailable (grayed-out) when they are not applicable to the current document selection.
I just checked v3.3 and it only makes those buttons available when you've selected text. That way they don't blink when you're just typing. I think that's a much better implementation.
User avatar
admin
Site Admin
Posts: 2730
Joined: Wed Jun 05, 2002 10:48 pm
Contact:

Re: v4.3.3.0 "don't" and "doesn't" are being autocorrected to "don'it" and "doesn'it"

Post by admin »

Atlantis can load the AutoCorrect "replace with" pairs from external UTF-8 (with BOM) or ANSI files. UTF-8 (without BOM) is not supported.

When there is no selection in the document, the "change case" commands in recent releases of Atlantis are applicable to current word.
Post Reply